Cross River - PushToPay degraded performance
Incident Report for CRB Card Payments
Resolved
This incident has been resolved.
Posted Apr 04, 2024 - 18:44 EDT
Update
After a thorough investigation, we have identified that our third-party vendor was the root cause of the issue. Operations and processes have resumed, and are now back to normal.
Posted Apr 04, 2024 - 18:41 EDT
Update
The root cause has been identified, and our teams are actively working towards a resolution. Further updates will be provided as progress is made.
Posted Apr 04, 2024 - 16:55 EDT
Identified
Our NOC team has identified a possible degradation of performance to the web API in push/pull to card transactions and card signup.
This is currently under investigation. Customers may experience some performance and availability issues.

For more information please contact p2p.support@crossriver.com
Posted Apr 04, 2024 - 15:39 EDT
This incident affected: Card Payments Authorization Service, Card Payments Pull Service, and Card Payments Push Service.