Investigating P2P Transfer Processing Delays

Incident Report for CRB Card Payments

Resolved

We are aware of an issue affecting P2P transfers that may cause increased processing times. Some transactions may remain pending longer than expected.

Our engineering team is actively investigating the issue and working to resolve it as quickly as possible.
Posted Aug 27, 2026 - 06:22 EDT
This incident affected: Production (Card Payments Pull Service).