Cross River - PushToPay degraded performance

Incident Report for CRB Card Payments

Resolved

The technical issue affecting P2PE has been successfully resolved. All systems have been restored to full operational status and are functioning normally.
Posted Oct 21, 2025 - 02:28 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2025 - 02:17 EDT

Identified

Our NOC team has identified a possible degradation of performance, due to a third-party outage.
This is currently under investigation. Customers may experience some performance and availability issues.

For more information please contact p2p.support@crossriver.com
Posted Oct 21, 2025 - 01:47 EDT
This incident affected: Card Payments Authorization Service, Card Payments Pull Service, and Card Payments Push Service.