Cross River - PushToPay degraded performance

Incident Report for CRB Card Payments

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 07:04 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 06:36 EDT

Update

Please note that some Cross River services have been impacted by an outage with our third party cloud provider. We are currently monitoring and will provide an update in due course.

we apologize for any inconvenience this may cause.
Posted Oct 20, 2025 - 06:07 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 05:35 EDT

Investigating

Our NOC team has identified a possible degradation of performance, due to a third-party outage.
This is currently under investigation. Customers may experience some performance and availability issues.

For more information please contact p2p.support@crossriver.com
Posted Oct 20, 2025 - 05:34 EDT
This incident affected: Card Payments Authorization Service, Card Payments Pull Service, and Card Payments Push Service.